当前位置: 首页>>技术教程>>正文


在ubuntu上运行eclipse的问题?

, ,

问题描述

我在ubuntu上下载了eclipse。但是当我运行它时会显示以下错误。

A Java Runtime Environment (JRE) or Java Development Kit (JDK)
must be available in order to run Eclipse. No Java virtual machine
was found after searching the following locations:
/home/awan/eclipse/jre/bin/java
java in your current PATH

有人可以帮我解决这个问题。我在ubuntu上没有这方面的经验。

谢谢

最佳解决方案

您需要安装openjdk-7-jreoracle-java7-jre软件包。

sudo apt-get install openjdk-7-jre

请注意,openjdk-7-jre更易于安装,因为它可以通过标准的Ubuntu存储库获得,而您必须使用java-package自己构建oracle-java7-jre

次佳解决方案

如果您已经安装了java **,则需要将Java-Path添加到eclipse.ini

就我而言,它位于:

/usr/lib/eclipse/eclipse.ini

你需要在”openFile”语句下直接添加,你用java路径替换路径:

-vm
/usr/lib/jvm/java-7-openjdk/bin/java    //!replace with your path to java!

**通过键入命令检查是否安装了java

java -version 

要么

javac -version

如果您确定已安装java,但未找到,则可能安装了多个版本,请通过以下方式检查:

sudo update-alternatives --config java

并先选择安装

第三种解决方案

我通过在/usr/bin中创建了指向VM的符号链接java来解决它。

脚步 :

  1. http://www.oracle.com/technetwork/java/javase/downloads/index.html?ssSourceSiteId=otnjp下载适当版本的Oracle JDK

  2. 将其解压缩到任何文件夹。例如:tar zxvf~ /Downloads /jdk-8u5-linux-x64.tar.gz~ /DEV

  3. 创建名称为java的符号链接:cd /usr/bin ln -s ~/DEV/jdk1.8.0_05/bin/java java

第四种方案

您需要将JDK添加到PATH。

This链接应该可以帮助您入门。

第五种方案

您需要安装JDK或OpenJDK(Eclipse仅正式支持前者,但后者主要工作)。

第六种方案

您需要一个可以在Eclipse中执行Java指令的Java环境才能运行它。

在包管理器中安装合适的Java包,然后重试。请注意,Eclipse不需要JDK,JRE就足够了。

参考资料

本文由Ubuntu问答整理, 博文地址: https://ubuntuqa.com/article/7202.html,未经允许,请勿转载。

相关内容