當前位置: 首頁>>技術教程>>正文


為什麽natty-proposed建議升級到Firefox Beta版?

, ,

問題描述

好吧,我今天加載了更新管理器,它想用5.0beta5代替Firefox 4.0.1。要仔細檢查,我解雇了apt-cache policy firefox,它是:

 5.0~b5+build1+nobinonly-0ubuntu0.11.04.1 0
    500 http://gb.archive.ubuntu.com/ubuntu/ natty-proposed/main amd64 Packages

我以前從未聽說過Ubuntu這樣更新瀏覽器mid-release。特別是沒有beta。

有人知道幕後發生了什麽嗎?為什麽Natty的瀏覽器更新到新的主要版本?

最佳答案

Firefox 5.0隻是針對4.0.1用戶的下一個常規安全更新,計劃於6月21日發布。但是,由於使用了Firefox的新發行模型,我們還需要同時更新Firefox的翻譯(並且我們將對以後的所有Firefox安全更新進行更新)。這意味著我們還需要在Firefox 5.0更新中提供更新的language-pack-xx- *軟件包。

為了為此做準備,我們將在5.0版本的同時將Firefox翻譯從主要語言包中分離出來。這意味著在將來,我們將不需要重新啟動Firefox安全更新的所有語言包(這會招致相當大的QA損失)。由於包裝的拆分以及新語言包都包含了所有其他應用程序(從Launchpad導出)的更新翻譯,因此它們需要在natty-proposed中進行擴展測試,然後我們才能在6月21日將其發布給所有人。但是,對其進行測試還取決於natty-proposed中新存在的split-out Firefox翻譯軟件包(否則,語言包測試人員將無法滿足這些軟件包的關係)。

我們決定將當前測試版上傳到natty-proposed,因為如果在開始測試natty-proposed中的語言包之前等待發布版本,我們將不得不延遲下一次安全更新。請注意,當前的Beta實際上比RC更像是RC(這是最終發行版本之前的最後一個計劃的Beta版本,並且從現在到6月21日之間不太可能更改)

我們不打算將Beta版本發布給所有用戶-我們將在6月21日將最終的5.0版本發布到natty-security和natty-updates時將其刪除。請記住,natty-proposed是一個opt-in存儲庫,在向所有用戶發布軟件包之前,我們會在其中上載軟件包以測試穩定的發行更新。

次佳答案

Firefox 5 final預定用於release on 21 Juny,它將很快成為下一個穩定版本。

瘋狂的版本顛簸可能是由Chromium /Chrome引起的,它喜歡每個月左右修改版本號。

可以在Mozilla Wiki: Features/Release Tracking for Firefox 5跟蹤新功能

參考資料

本文由Ubuntu問答整理, 博文地址: https://ubuntuqa.com/zh-tw/article/11748.html,未經允許,請勿轉載。