当前位置: 首页>>技术教程>>正文


如何在Ubuntu 13.10中安装Google-Earth 64bit,ia32-libs依赖性错误

ubuntuer 技术教程 , , , 去评论

问题描述

我想安装Google-Earth&它需要ia32-libs。所以,我做了apt-get install ia32-libs,但错误弹出:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

我该如何安装ia32-libs?

最佳解决办法

在重新打包Google地球之前,这只是一种解决方法。

Google地球构建包

  1. 下载Google Earth x64 .DEB

  2. 打开终端,复制&粘贴以下命令并按Enter键

    sudo apt-get install libc6:i386 lsb-core
    
  3. 打开下载文件夹

  4. 右键单击Google Earth .deb package&选择Extract Here

  5. 打开提取文件的文件夹。

  6. 打开DEBIAN文件夹

  7. 使用gedit打开control文件

  8. 删除整行:取决于:lsb-core(> = 3.2),ia32-libs

  9. 现在点击保存,&退出控制文件

  10. 现在删除您下载的原始Google Earth .DEB程序包

  11. 创建一个名为getfix的文件夹,现在将提取的Google地球文件夹移动到getfix文件夹中

现在我们要重建Google Earth .deb包:

  1. 打开终端,复制/粘贴以下命令,然后按Enter

    dpkg -b ~/Downloads/getfix/google-earth-stable_current_amd64
    
  2. 复制/粘贴以下命令(这将安装重新打包的.deb)

    sudo dpkg -i ~/Downloads/getfix/google-earth-stable_current_amd64.deb
    

次佳解决办法

对于Ubuntu 13.10 /14.04 /1404.1 64位安装

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 \
libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 \
libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

对于Ubuntu 14.04.2映像64位安装(当使用14.04.2映像时,您获得mesa-lts-utopic堆栈,因此一个包不同,即libgl1-mesa-glx-lts-utopic:i386

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 \
libglu1-mesa:i386 libgl1-mesa-glx-lts-utopic:i386 libxext6:i386 \
libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

然后获得当前的i386包&安装它 – http://www.google.com/earth/download/ge/agree.html

第三种解决办法

在撰写本答案时,此处描述的所有方法都不起作用。但是我安装了32位版本,它在64位13.10 Kubuntu上工作正常。似乎Google Earth软件包毕竟是32位,它使用ia32libs使其在64位上运行。希望这可以帮助

参考资料

本文由Ubuntu问答整理, 博文地址: https://ubuntuqa.com/article/6505.html,未经允许,请勿转载。

相关文章