当前位置: 首页>>技术教程>>正文


Youtube说“此视频目前无法使用”

ubuntuer 技术教程 , , 去评论

问题描述

Ubuntu 12.04上的Chromium。 Youtube说:

This video is currently unavailable

我不知道为什么,但有些视频就是这种情况,但不是全部。嗯,大多数视频。我不知道出了什么问题。

有人帮吗?

最佳解决思路

您可以通过加入YouTube’s HTML5 trial来测试Chromium的内置 Flash播放器是否存在问题,这会将您切换到YouTube的新HTML5视频播放器。如果视频有效,那么您的Chromium /Flash播放器安装就会出现问题。尝试重新安装它。如果它们仍无法正常工作,则可能是YouTube端或ISP端或两者之间的问题。你能评论一个给你这个错误的视频的例子吗?

此外,这似乎是YouTube错误,还是您从Flash /Chromium收到的错误?

次佳解决思路

我正在使用Chromium Version 28.0.1500.52 Ubuntu 12.10 (28.0.1500.52-0ubuntu1.12.10.3)并面临同样的问题。要解决问题,您需要删除当前的一组 chrome 编解码器:

sudo apt-get remove chromium-codecs-ffmpeg

他们安装类似但额外的包:

sudo apt-get install chromium-codecs-ffmpeg-extra

YouTube问题将被删除,视频将播放。

因此,通用解决方案可以更新chrome /chromium编解码器。

在删除chromium-codecs-ffmpeg时,您还可能面临安装chromium-codecs-ffmpeg-extra的建议。只需应用建议即可安装额外版本的软件包。

此外,更新当前版本的chrome浏览器以获取最新版本将非常有用:

sudo apt-get install chromium-browser

谢谢

第三种解决思路

通过使用包含所有编解码器的包替换默认的有限patent-free编解码器集来解决此问题。跑:

sudo apt-get install chromium-codecs-ffmpeg-extra

(当询问是否要删除chromium-codecs-ffmpeg并安装chromium-codecs-ffmpeg-extra时,回答“是”。)

安装完成后,您需要重新启动Chromium。

为什么会这样

Chromium(出于政治/意识形态的原因)默认只安装了patent-free编解码器(Ogg,Vorbis和Theora),这意味着网络上的大量视频和音频内容将采用Chromium无法理解的格式。

chromium-codecs-ffmpeg-extra软件包包含patent-free和一系列(广泛使用的)专利编解码器。

chromium-codecs-ffmpeg-extra包装的描述:

This package contains the multi-threaded ffmpeg codecs needed for the HTML5 <audio> and <video> tags. In addition to the patent-free ogg, vorbis and theora codecs, aac / ac3 / mpeg4audio / h264 / mov / mp3 are also included. See chromium-codecs-ffmpeg if you prefer only the patent-free codecs

参考资料

本文由Ubuntu问答整理, 博文地址: https://ubuntuqa.com/article/2976.html,未经允许,请勿转载。

相关文章