當前位置: 首頁>>技術問答>>正文


我如何安裝Skype?

, ,

問題描述

我想安裝Skype,但我無法在軟件中心找到它或使用新立得軟件包管理器。誰能幫我?

最佳解決方案

注意:舊版Skype for Linux應用程序(v4。*)現在已停用,並從Canonical的合作夥伴存儲庫1中刪除,因此大多數答案都已過時。 Skype可能會將您從這些不受支持的客戶端注銷。 2

截至2017年7月的所有Ubuntu版本

要安裝Skype for Linux應用程序(版本8+),請執行以下操作:

  1. Download the Deb package for Skype for Linux with your favourite web browser or HTTP client.

    • For a terminal-based solution use:

      wget https://repo.skype.com/latest/skypeforlinux-64.deb 
  2. Install the Deb package with your favourite package manager, e. g. Software Center or GDebi.

    • For a terminal-based solution or to debug the package installation use:

      sudo dpkg -i skypeforlinux-64.deb sudo apt install -f 
  3. You’re done! When you installed the package it automatically added a repository […] to keep your installation of Skype up to date via Ubuntu’s package update process.

(source)

新的Skype應用程序僅適用於Ubuntu的64位(amd64)安裝。


1您可以通過在合作夥伴存儲庫軟件包列表中搜索skype來驗證它是否被刪除:

wget -O- "http://archive.canonical.com/ubuntu/dists/$(lsb_release -sc)/partner/binary-$(dpkg --print-architecture)/Packages.gz" | gzip -d |
grep -xFe 'Package: skype' || echo 'Not found!'

次佳解決方案

注意:舊版Skype for Linux應用程序(v4。*)現在已停用,並已從Canonical的合作夥伴存儲庫中刪除,因此與其他大多數答案一樣,此答案已過時。請參閱a newer answer

11.10及以上

從Ubuntu 11.10開始,multi-arch用於以前使用ia32-libs的應用程序。以下是AMD64上Skype的官方工作(我代表發布團隊):

Skype是一個32位二進製文​​件,在Ubuntu 11.10下,您必須為Ubuntu 11.10 i386和amd64版本安裝Skype的32位版本。

您可以從Ubuntu合作夥伴資源庫中獲取此信息。

要從軟件源中的合作夥伴存儲庫如何啟用“partner”存儲庫?中獲取它,然後從軟件中心獲取它:

點擊ubuntu按鈕,然後搜索”Software Sources”,點擊它,然後進入“其他軟件選項卡”:

software-installation,skype,ubuntu

當你點擊關閉運行軟件中心,並搜索Skype。

software-installation,skype,ubuntu


如果仍然沒有在software-center中顯示Skype,請關閉應用程序。

在終端類型中:

sudo apt-get update
sudo apt-get --reinstall install software-center

這將強製更新包管理,然後為software-center更新software-catalog。

第三種解決方案

11.10&在命令行上方

要從命令行啟用合作夥伴存儲庫,請編輯/etc/apt/sources.listsudoedit /etc/apt/sources.list並從以下兩行開頭刪除#

12.04

deb http://archive.canonical.com/ubuntu precise partner  
deb-src http://archive.canonical.com/ubuntu precise partner

然後更新你的apt緩存並安裝它:

sudo apt-get update
sudo apt-get install skype:i386 libasound2-plugins:i386

第四種方案

注意:舊版Skype for Linux應用程序(v4。*)現在已停用,並已從Canonical的合作夥伴存儲庫中刪除,因此與其他大多數答案一樣,此答案已過時。請參閱a newer answer

適用於Ubuntu 12.04及以上版本

命令行方式:

sudo add-apt-repository "deb http://archive.canonical.com/ $(lsb_release -sc) partner"
sudo apt-get update 
sudo apt-get install skype

HELP

第五種方案

注意:舊版Skype for Linux應用程序(v4。*)現在已停用,並已從Canonical的合作夥伴存儲庫中刪除,因此與其他大多數答案一樣,此答案已過時。請參閱a newer answer

10.10

要安裝Skype,您需要啟用規範合作夥伴存儲庫。

添加這個存儲庫:deb http://archive.canonical.com/ubuntu maverick partner

這可能已經可用但未安裝。如果是這樣,隻需勾選合作夥伴存儲庫旁邊的複選框:

software-installation,skype,ubuntu

當你關閉軟件源窗口時,它應該刷新你的軟件包,Skype應該可以從軟件中心安裝。

第六種方案

  1. 我去了Skype web site

  2. 然後我選擇“下載Skype for Linux DEB”。

    software-installation,skype,ubuntu

  3. 下載後,我隻需將double-click文件或right-click文件打開並通過軟件中心打開,然後單擊安裝。它將安裝您下載的Deb軟件包,完成後您會在搜索框中輸入Skype。如果你喜歡,你可以固定它的圖標。

    software-installation,skype,ubuntu

第七種方案

不推薦手動安裝軟件包。但是我一直通過Ubuntu Package Manager手動安裝Skype軟件包,而且沒有任何問題。隻要確保您檢查安裝過程中顯示的任何警告。

轉到:http://www.skype.com/intl/en/get-skype/on-your-computer/linux/

下載64位Ubuntu軟件包。下載完成後,雙擊該軟件包以通過Ubuntu軟件包管理器開始安裝。它會下載任何依賴和安裝

第八種方案

最近,Skype對於Linux用戶來說變得非常容易。事實上,網站上的軟件包可以正常工作,但是軟件倉庫中的軟件包不適合我(在Ubuntu 16.04上)。隻需進入skype.com和download Debian .deb文件,您可以通過double-clicking直接打開文件夾中的下載文件,並通過軟件中心進行安裝。截至目前,它仍處於Beta版本。

第九種方案

12.04及以上

在遵循11.04之前的指示之後,軟件中心中沒有顯示出skype出現問題。

您仍然需要按照GUI的其他說明添加合作夥伴資源庫,或者使用終端編輯/etc/apt/sources.list,以便該行

deb http://archive.canonical.com/ubuntu precise partner

沒有評論(散列)。

然後您需要更新存儲庫信息:

sudo apt-get upgrade

然後可以從命令行安裝Skype:

sudo apt-get install skype

第十種方案

Skype和其他一些受歡迎的應用程序目前可以(2017年8月)與Flatpack一起安裝。

要在Ubuntu上使用最新版本的Flatpack,it is recommended要使用PPA:

sudo add-apt-repository ppa:alexlarsson/flatpak
sudo apt update
sudo apt install flatpak

要為所有用戶安裝Skype flatpakexecute

flatpak install --from https://s3.amazonaws.com/alexlarsson/skype-repo/skype.flatpakref

重新啟動圖形shell或注銷並登錄後,Skype應顯示在應用程序菜單和搜索結果中,然後可將其添加到收藏夾中。它也可以從命令行開始

flatpak run com.skype.Client

參考資料

本文由Ubuntu問答整理, 博文地址: https://ubuntuqa.com/zh-tw/article/876.html,未經允許,請勿轉載。