當前位置: 首頁>>技術教程>>正文


lubuntu – “眾所周知,Shockwave Flash容易受到攻擊”警告

, ,

問題描述

晚上好!

今天,我沒有任何問題地關閉了計算機,然後出去了。當我回來嘗試上網時,我發現我的Firefox開始給我這個問題:

“眾所周知,Shockwave Flash容易受到攻擊”

我對此進行了研究,然後卸載並重新安裝了Adobe Flash Player插件,但沒有用。我的Flash Player也是最新的。 (版本:11.02.202.481)。我順便使用Lubuntu。

謝謝您的支持!

最佳方案

Mozilla, which develops Firefox, imposed the block because recently unearthed bugs in Flash were being actively used by cyber-thieves.

The bugs were detailed in a cache of documents stolen from security firm Hacking Team that was hit by attackers last week.

Adobe said it took Flash’s security “seriously” and was planning bug fixes.

Source

現在無法在沒有任何提示的情況下使其始終處於活動狀態,但是您應該能夠通過按Activate Adobe Flash來允許Flash播放單個內容:

或者,您可以為該站點啟用它,甚至選擇記住要使其在該站點處於活動狀態:

次佳方案

在Ubuntu和Linux以及最新版本中獲得Flash的公認方法是使用Google Chrome,因為它是唯一提供Flash版本的瀏覽器。

Adobe停止在版本11左右支持Linux的Flash(甚至在Firefox中)。它們不再為Linux發行任何’new’ Flash版本以及Firefox處理插件的方式。由於版本號真的很舊(18是最新的Flash總體版本,而11是可用於Linux的最後一個受支持的Firefox插件版本),以及其他安全方麵的考慮,Firefox會自動禁用這些’old’版本。這適用於所有操作係統,而不僅僅是Ubuntu和* nix。 (雖然@ParanoidPanda是正確的,但他們現在在所有平台上強製執行一些額外版本,但這並不是在Ubuntu /Firefox中發出此警告的主要原因)。


但是,即使Adobe取消了對Firefox的Linux等插件API格式的原生支持,Adobe和Google也達成了協議。根據該協議,Google可以發布使用Pepper API框架的更新Flash,並將其包含在Google中。

如果您安裝了Chrome,則可以將某些包裝器程序安裝到Firefox中,以利用Chrome中的Pepper Flash的使用。但是,在這種情況下,大多數用戶隻是切換到Chrome。

我建議您使用install Chrome並將其用於瀏覽和使用Flash網站(前提是您保持最新狀態)。


但是請注意,Firefox的策略無法繞過此更改。 There is a page in the Security Team’s knowledge base that details this issue a little more, or at least, provides a timeline for all the events related to this.

參考資料

本文由Ubuntu問答整理, 博文地址: https://ubuntuqa.com/zh-tw/article/11614.html,未經允許,請勿轉載。